SPC 文件与 Excel 输出
Easson2D SPC 支持将当前统计数据保存为 SPC 文件,也可以将当前查看的分析结果发送到 Excel。
SPC 文件主要用于保存和继续分析历史测量数据,而 Excel 输出则适合制作检验记录或进一步整理统计结果。
SPC 文件
SPC 数据可以保存为:
.e2c 文件
该文件主要保存:
- SPC 管制项目
- 标准值和公差信息
- 已测量的样品数据
- 当前样本容量等 SPC 设置
SPC 文件与 Easson2D 的测量程序文件相互独立。
可以简单理解为:
- Easson2D 程序文件:保存怎么测量
- SPC
.e2c文件:保存已经得到的 SPC 测量数据
新建 SPC 文件
通过:
文件 → 新建
可以建立新的 SPC 数据文件。
如果当前文件已经包含修改但尚未保存,软件会先提示是否保存现有数据。
打开 SPC 文件
通过:
文件 → 打开
可以打开之前保存的 .e2c 文件。
打开旧文件后,可以继续运行 Easson2D 测量程序,新产生的样品数据会继续追加到已有 SPC 数据之后。
因此,同一批产品的 SPC 数据可以分多次测量并持续累积。
保存与另存为
通过:
文件 → 保存
可以保存当前 SPC 数据。
如果希望保存为新的文件,则可以使用:
文件 → 另存为
建议根据产品、批次或测量日期使用容易辨认的文件名称,方便以后重新打开和查看。
输出格式
通过:
选项 → 输出格式
可以选择样品列表中需要显示和输出的统计信息。
可选择的内容包括:
- 标准值
- 上公差
- 下公差
- 平均值
- 最大值
- 最小值
- 极差
- CPK
这些设置会影响样品列表的显示内容,并同时影响对应的 Excel 输出。
发送到 Excel
点击工具栏中的:
发送到 Excel
可以把当前查看的 SPC 数据发送到 Microsoft Excel。
需要注意:
Excel 输出的是当前选中的管制项目和当前正在查看的 SPC 视图。
例如当前选择"圆1直径",并正在查看简单分析图,则发送到 Excel 的就是"圆1直径"的简单分析结果。
不同视图的 Excel 输出
根据当前查看的内容,Excel 输出结果会有所不同。
样品列表和分组列表
主要输出表格形式的数据,包括测量值和相关统计信息。
简单分析图
会输出当前项目的统计数据,并将分析图一起加入 Excel。
SPC 控制图
会输出:
- 当前控制图
- 相关统计参数
- 分组或测量明细数据
因此,在发送到 Excel 前,建议先选择需要输出的管制项目和分析视图。
Excel 输出后的保存
点击"发送到 Excel"后,软件会自动打开 Microsoft Excel,并生成相应内容。
SPC 不会自动替用户保存 Excel 文件。
完成输出后,可以在 Excel 中根据需要进行:
- 保存
- 另存为
- 调整排版
- 打印
- 添加其他说明
如果电脑没有安装 Microsoft Excel,则无法正常使用该输出功能。
推荐使用流程
完成一批工件的 SPC 测量后,可以按照以下顺序整理结果:
保存 .e2c SPC 文件 → 选择需要查看的管制项目 → 切换到需要输出的列表或控制图 → 根据需要设置输出格式 → 点击"发送到 Excel" → 在 Excel 中保存最终报告
这样既可以保留完整的 SPC 原始数据,也可以将需要的统计结果整理成 Excel 文件用于报告、存档或发送给客户。